summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 21:09:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:22 -0500
commit08247055a6190ea28d04126ea25f78a2f02ff972 (patch)
tree1701d6cc5d062b8152d62fec64a543d8b244f7dc /gnu/packages
parenta768c3ecabc642588b12410fbb8e1425dc34d854 (diff)
downloadguix-08247055a6190ea28d04126ea25f78a2f02ff972.tar.gz
gnu: python-sphinx: Update to 4.2.0.
* gnu/packages/sphinx.scm (python-sphinx): Update to 4.2.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7d7e567dac..5fd63a617c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,26 +57,27 @@
 (define-public python-sphinx
   (package
     (name "python-sphinx")
-    (version "4.0.3")
+    (version "4.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Sphinx" version))
        (sha256
         (base32
-         "1f7vnk3g135b2zs9yq3kgrczxa91mhrlfw8243dpxsq8lbk5gwyz"))))
+         "19jq21py7m061v8142y2dbqrbv0adqcdjmharrdy34a432wqs1wl"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Requires Internet access.
-             (delete-file "tests/test_build_linkcheck.py")
-             (substitute* "tests/test_build_latex.py"
-               (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
-                "@pytest.mark.skip()"))
-             (invoke "make" "test"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Requires Internet access.
+               (delete-file "tests/test_build_linkcheck.py")
+               (substitute* "tests/test_build_latex.py"
+                 (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
+                  "@pytest.mark.skip()"))
+               (invoke "make" "test")))))))
     (propagated-inputs
      `(("python-babel" ,python-babel)
        ("python-docutils" ,python-docutils)