summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-05 13:03:06 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-05 14:45:15 +0100
commit0b36bd01e4ed2fc5a6afc11bd0272b036667c25e (patch)
tree1d60fcff9667519ea2ea969ab0592371c206b0d5 /gnu/packages
parentb970c0ed93280015a5d37419f1544a3bf04c25a9 (diff)
downloadguix-0b36bd01e4ed2fc5a6afc11bd0272b036667c25e.tar.gz
gnu: Add rust-core-foundation-0.9.
* gnu/packages/crates-io.scm (rust-core-foundation-0.9): New variable.
(rust-core-foundation-0.7): inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 28fc5dccd6..599d3b6796 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4684,33 +4684,50 @@ management.  It supports signed and private (encrypted, authenticated) jars.")
 intrinsics.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-core-foundation-0.7
+(define-public rust-core-foundation-0.9
   (package
     (name "rust-core-foundation")
-    (version "0.7.0")
+    (version "0.9.1")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "core-foundation" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "0wbias8f0m5kyn2pcksi0h58fdslams6nmf16w78fgn42dx4rljp"))))
+        (base32 "0qhackx0i914nbhcwi6bbxnyyqqldgxc046gviak3a3f8apf528a"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
+     `(#:tests? #f             ;tests fail with a lot of "undefined reference"
        #:cargo-inputs
        (("rust-chrono" ,rust-chrono-0.4)
-        ("rust-core-foundation-sys" ,rust-core-foundation-sys-0.7)
+        ("rust-core-foundation-sys" ,rust-core-foundation-sys-0.8)
         ("rust-libc" ,rust-libc-0.2)
         ("rust-uuid" ,rust-uuid-0.5))))
     (home-page "https://github.com/servo/core-foundation-rs")
     (synopsis "Bindings to Core Foundation for macOS")
-    (description "This package provides bindings to Core Foundation for
-macOS.")
+    (description "This package provides bindings to Core Foundation for macOS.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-core-foundation-0.7
+  (package
+    (inherit rust-core-foundation-0.9)
+    (name "rust-core-foundation")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "core-foundation" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0wbias8f0m5kyn2pcksi0h58fdslams6nmf16w78fgn42dx4rljp"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-chrono" ,rust-chrono-0.4)
+        ("rust-core-foundation-sys" ,rust-core-foundation-sys-0.7)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-uuid" ,rust-uuid-0.5))))))
+
 (define-public rust-core-foundation-0.6
   (package
     (inherit rust-core-foundation-0.7)