summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 03:37:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:37 +0200
commit308ed1dd4459182b70f191a660f57f74c9beb483 (patch)
tree8a447834603ac0d80ce1a7e392d265bb96a9458a /gnu/packages
parente2fdc27bf179f16a8656d358975f1da558a9447e (diff)
downloadguix-308ed1dd4459182b70f191a660f57f74c9beb483.tar.gz
gnu: gpsd: Update to 3.23.1.
* gnu/packages/gps.scm (gpsd): Update to 3.23.1.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gps.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 03bff15760..de8ff13828 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -221,14 +221,14 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
 (define-public gpsd
   (package
     (name "gpsd")
-    (version "3.23")
+    (version "3.23.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download-mirror.savannah.gnu.org"
                            "/releases/gpsd/gpsd-" version ".tar.xz"))
        (sha256
-        (base32 "1px9im0qfn8k7mnvjcw5myakzd7mad2drwyzji400hpwyswjjr73"))))
+        (base32 "1hd8b09is4gd73lpsdywxxdx11iijikmqgxd0y57pic3yxnlcb6a"))))
     (build-system scons-build-system)
     (native-inputs
      `(("bc" ,bc)
@@ -261,8 +261,7 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
              (setenv "TAR" "noop")
              (substitute* "SConscript"
                (("envs = \\{\\}")
-                "envs = os.environ"))
-             #t))
+                "envs = os.environ"))))
          (add-after 'install 'wrap-python-scripts
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -283,8 +282,7 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
                            (wrap-program (string-append out "/bin/" script)
                              `("PYTHONPATH" ":" prefix (,pythonpath))))
                          '("gegps" "gpscat" "gpsfake" "gpsprof"
-                           "ubxtool" "xgps" "xgpsspeed" "zerk")))
-             #t)))))
+                           "ubxtool" "xgps" "xgpsspeed" "zerk"))))))))
     (synopsis "GPS service daemon")
     (description
      "@code{gpsd} is a service daemon that monitors one or more GPSes or AIS