summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 02:38:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:36 +0200
commit4d5f7986d687f997ae8f1875cef36441e9bea035 (patch)
tree9d79416838ab4d8408d482121baaa4d1757f6aa5 /gnu/packages
parent15e5d22fcbac028b8312d2cf3cd20844d9ee80e3 (diff)
downloadguix-4d5f7986d687f997ae8f1875cef36441e9bea035.tar.gz
gnu: libcacard: Update to 2.8.1.
* gnu/packages/spice.scm (libcacard): Update to 2.8.1.
[source]: Remove patch.
* gnu/packages/patches/libcacard-unknown-variable.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/libcacard-unknown-variable.patch50
-rw-r--r--gnu/packages/spice.scm7
2 files changed, 3 insertions, 54 deletions
diff --git a/gnu/packages/patches/libcacard-unknown-variable.patch b/gnu/packages/patches/libcacard-unknown-variable.patch
deleted file mode 100644
index 830a3ee8c0..0000000000
--- a/gnu/packages/patches/libcacard-unknown-variable.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Fix Meson error when test dependencies are missing.
-
-Based on this upstream commit, with some adjustments to apply on 2.8.0:
-https://gitlab.freedesktop.org/spice/libcacard/-/commit/cf6121deb47e437aa566cfeb29a03da93c432394
-
-diff --git a/tests/meson.build b/tests/meson.build
-index 87945a2..baefaf5 100644
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -9,15 +9,6 @@ modutil_dep = find_program('modutil', required: false)
- openssl_dep = find_program('openssl', required: false)
- softhsm_util_dep = find_program('softhsm2-util', required: false)
- 
--if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
--  softhsm = custom_target(
--    'softhsm2.conf',
--    command: find_program('setup-softhsm2.sh'),
--    capture: true,
--    output: 'setup-softhsm2.log',
--  )
--endif
--
- libcacard_test = executable(
-   'libcacard',
-   ['libcacard.c', 'common.c'],
-@@ -64,9 +55,18 @@ hwtests_test = executable(
-   dependencies: [libcacard_dep],
- )
- 
--test(
--  'hwtests',
--  hwtests_test,
--  depends: [softhsm],
--  env: env,
--)
-+if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
-+  softhsm = custom_target(
-+    'softhsm2.conf',
-+    command: find_program('setup-softhsm2.sh'),
-+    capture: true,
-+    output: 'setup-softhsm2.log',
-+  )
-+
-+  test(
-+    'hwtests',
-+    hwtests_test,
-+    depends: [softhsm],
-+    env: env,
-+  )
-+endif
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index d9daac1185..9c88b63108 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -329,17 +329,16 @@ resolution scaling on graphical console window resize.")
 (define-public libcacard
   (package
     (name "libcacard")
-    (version "2.8.0")
+    (version "2.8.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "https://gitlab.freedesktop.org/spice/libcacard/uploads/"
-                    "9d8f24b131bcbbd7846727ea92952cb5"
+                    "13b249e695a0d9aa7cb501b1a85ebab1"
                     "/libcacard-" version ".tar.xz"))
-              (patches (search-patches "libcacard-unknown-variable.patch"))
               (sha256
                (base32
-                "0azj3rqr2smg0lai24xrn3zr628xmjfrzcggay877zrr64ybj1c0"))))
+                "1rrjlclm6ad63gah1fa4yfwrz4z6vgq2yrybbvzvvdbxrgl4vgzv"))))
     (build-system meson-build-system)
     (arguments
      '(#:tests? #f                      ; TODO Tests require gnutls built with