summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 15:23:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:06 +0000
commitc3a3a4a7619456a60caf4e2dc3be91dc6adc3a2e (patch)
treea31d6af30b6a9d47358b527faca2cb7e587a98fd /gnu/packages
parent9e6b25505ac07ffbf5ce16e4e08ae3dd626587b8 (diff)
downloadguix-c3a3a4a7619456a60caf4e2dc3be91dc6adc3a2e.tar.gz
gnu: gamin: Recognise aarch64 as architecture when cross-compiling.
* gnu/packages/gnome.scm
  (gamin)[arguments]<#:phases>{replace-config.sub}: Update 'config.sub'
  when cross-compiling.
  (gamin)[native-inputs]: Add "config" when cross-compiling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4a6266786a..5e24090b64 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -62,6 +62,7 @@
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11244,6 +11245,13 @@ repository and commit your work.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         ;; The 'config.sub' is too old to recognise aarch64.
+         ,@(if (and=> (%current-target-system) target-aarch64?)
+               `((add-after 'unpack 'replace-config.sub
+                   (lambda _
+                     (delete-file "config.sub")
+                     (symlink (which "config.sub") "config.sub"))))
+               '())
          (add-after 'unpack 'remove-deprecated-macro
            (lambda _
              (substitute* '("server/gam_node.c"
@@ -11255,7 +11263,10 @@ repository and commit your work.")
     (inputs
      `(("glib" ,glib)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)
+       ,@(if (and=> (%current-target-system) target-aarch64?)
+             `(("config" ,config))
+             '())))
     (home-page "https://people.gnome.org/~veillard/gamin/")
     (synopsis "File alteration monitor")
     (description