summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 20:49:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:10 -0500
commitc738a054cac00441a4f697f0b40705d0b3f4a7a7 (patch)
treea9d5c9c54744dc38810f302fea7e63dc0a903b8e /gnu/packages
parent9635119a61a9ab1b023558727fcdf1816fdc7fc6 (diff)
downloadguix-c738a054cac00441a4f697f0b40705d0b3f4a7a7.tar.gz
gnu: fontconfig: Add a search path for XDG_DATA_DIRS.
Fixes <https://issues.guix.gnu.org/31403>.

* gnu/packages/fontutils.scm (fontconfig)[source]: Fix indentation.
[configure-flags]: Drop the "--with-add-fonts" configure option as it's no
longer necessary/desirable to special case the system and user profiles.
[native-search-paths]: New search path.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 264450650d..2575bfb386 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -326,14 +326,13 @@ Font Format (WOFF).")
      (name "fontconfig-minimal")
      (version "2.13.94")
      (source (origin
-            (method url-fetch)
-            (uri (string-append
-                  "https://www.freedesktop.org/software/"
-                  "fontconfig/release/fontconfig-" version ".tar.xz"))
-            (sha256
-             (base32
-              "0g004r0bkkqz00mpm3svnnxn7d83158q0yb9ggxryizxfg5m5w55"))
-             (patches (search-patches "fontconfig-cache-ignore-mtime.patch"))))
+               (method url-fetch)
+               (uri (string-append
+                     "https://www.freedesktop.org/software/"
+                     "fontconfig/release/fontconfig-" version ".tar.xz"))
+               (sha256 (base32
+                        "0g004r0bkkqz00mpm3svnnxn7d83158q0yb9ggxryizxfg5m5w55"))
+               (patches (search-patches "fontconfig-cache-ignore-mtime.patch"))))
      (build-system gnu-build-system)
      ;; In Requires or Requires.private of fontconfig.pc.
      (propagated-inputs `(("expat" ,expat)
@@ -355,12 +354,7 @@ Font Format (WOFF).")
               ;; register the default fonts
               (string-append "--with-default-fonts="
                              (assoc-ref %build-inputs "font-dejavu")
-                             "/share/fonts")
-
-              ;; Register fonts from user and system profiles.
-              (string-append "--with-add-fonts="
-                             "~/.guix-profile/share/fonts,"
-                             "/run/current-system/profile/share/fonts"))
+                             "/share/fonts"))
         #:phases
         (modify-phases %standard-phases
           (add-before 'check 'skip-problematic-tests
@@ -392,6 +386,12 @@ high quality, anti-aliased and subpixel rendered text on a display.")
                                         ; The exact license is more X11-style than BSD-style.
      (license (license:non-copyleft "file://COPYING"
                                     "See COPYING in the distribution."))
+     (native-search-paths
+      ;; Since version 2.13.94, fontconfig knows to find fonts from
+      ;; XDG_DATA_DIRS.
+      (list (search-path-specification
+             (variable "XDG_DATA_DIRS")
+             (files '("share")))))
      (home-page "https://www.freedesktop.org/wiki/Software/fontconfig"))))
 
 ;;; The documentation of fontconfig is built in a separate package, as it