summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-11-04 08:27:15 -0400
committerMark H Weaver <mhw@netris.org>2021-11-04 08:27:15 -0400
commit1007eb4874b7d3d2e0ecda07157f5794a0591ea2 (patch)
treeeb5ab38a6236a8038eaedf4a685c7933507f4bcd /gnu/packages
parent72bf3c0b79f6f0e93d26c4fbd95c7039311a120e (diff)
downloadguix-1007eb4874b7d3d2e0ecda07157f5794a0591ea2.tar.gz
Revert "gnu: webkitgtk: Use GCC 11 instead of Clang."
This reverts commit 63f78f6a6ea0d33f3b1fa68c7285cfb865677211.
It led to broken builds of epiphany, gnome-online-accounts, yelp,
zenity, surf, and possibly others.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 7384ead14b..e54b680855 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -295,6 +295,11 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                  (("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
                   (string-append wpebackend-fdo "/lib/" all)))
                #t)))
+         (add-before 'configure 'prepare-build-environment
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "CC" "clang")
+             (setenv "CXX" "clang++")
+             #t))
          (add-after 'install 'move-doc-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -304,8 +309,8 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                             (string-append doc "/share/gtk-doc"))
                #t))))))
     (native-inputs
-     `(("bison" ,bison)
-       ("gcc" ,gcc-11)
+     `(("clang" ,clang-11)
+       ("bison" ,bison)
        ("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection)