summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-03-17 16:13:52 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-04-11 14:48:26 -0700
commit8aae96b44c2e84f31574200aa71c6ee4979b1620 (patch)
tree176d63bea238c7bd267cc2b55f9c786691aca89b /gnu/packages
parent6413d0898b92efda8213b3ced0b6d1c736726b89 (diff)
downloadguix-8aae96b44c2e84f31574200aa71c6ee4979b1620.tar.gz
gnu: genext2fs: Update to 1.5.0.
* gnu/packages/linux.scm (genext2fs): Update to 1.5.0.
  [source] Update URL.
  [arguments] Remove 'apply-debian-patches phase.
  [home-page] Update URL.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 5 insertions, 20 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c31113377c..a405837bb1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8401,34 +8401,19 @@ from the xfsprogs package.  It is meant to be used in initrds.")
 (define-public genext2fs
   (package
     (name "genext2fs")
-    (version "1.4.1-4")
+    (version "1.5.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/jeremie-koenig/genext2fs")
-                    ;; 1.4.1-3 had a VCS tag but 1.4.1-4 doesn't.
-                    (commit "9ee43894634998b0b2b309d636f25c64314c9421")))
+                    (url "https://github.com/bestouff/genext2fs")
+                    (commit "474111097321f03de9e009aa9f7d4a8948e310b2")))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "0ib5icn78ciz00zhc1bgdlrwaxvsdz7wnplwblng0jirwi9ml7sq"))))
+               (base32 "14lgvml5zz99845ja47jpf4iirjzfqv36ffzachh3hw2ggji9c7l"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'apply-debian-patches
-           ;; Debian changes (the revision after ‘-’ in VERSION) are
-           ;; maintained as separate patches.  Apply those relevant to us.
-           (lambda _
-             (for-each
-              (lambda (file-name)
-                (invoke "patch" "-p1" "-i"
-                        (string-append "debian/patches/" file-name)))
-              (list "blocksize+creator.diff" ; add -B/-o options
-                    "byteswap_fix.diff"))
-             #t)))))
     (native-inputs
      (list autoconf automake))
-    (home-page "https://github.com/jeremie-koenig/genext2fs")
+    (home-page "https://github.com/bestouff/genext2fs")
     (synopsis "Generate ext2 file system as a normal user")
     (description "This package provides a program to generate an ext2
 file system as a normal (non-root) user.  It does not require you to mount