summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-01-11 19:33:05 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-16 22:13:21 +0100
commit138adbbe051bcc83210b3197f62b8f7f70b0f16c (patch)
tree6a4737be64fd04c701d6ddfeff463ba31fdf07e3 /gnu/packages
parent2f4d08ee7f897e254c6e533ad2d69c7fe4998f38 (diff)
downloadguix-138adbbe051bcc83210b3197f62b8f7f70b0f16c.tar.gz
gnu: Add python-autopep8.
* gnu/packages/python.scm (python-autopep8, python2-autopep8): New variables.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ddf276de09..a9792afe25 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4157,6 +4157,34 @@ SQLAlchemy Database Toolkit for Python.")
 (define-public python2-alembic
   (package-with-python2 python-alembic))
 
+(define-public python-autopep8
+  (package
+  (name "python-autopep8")
+  (version "1.2.4")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (pypi-uri "autopep8" version))
+     (sha256
+      (base32
+       "18parm383lfn42a00wklv3qf20p4v277f1x3cn58x019dqk1xqrq"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-pep8" ,python-pep8)))
+  (home-page "https://github.com/hhatto/autopep8")
+  (synopsis "Format Python code according to the PEP 8 style guide")
+  (description
+    "@code{autopep8} automatically formats Python code to conform to
+the PEP 8 style guide.  It uses the pycodestyle utility to determine
+what parts of the code needs to be formatted.  @code{autopep8} is
+capable of fixing most of the formatting issues that can be reported
+by pycodestyle.")
+  (license (license:non-copyleft
+            "https://github.com/hhatto/autopep8/blob/master/LICENSE"))))
+
+(define-public python2-autopep8
+  (package-with-python2 python-autopep8))
+
 (define-public python-distutils-extra
   (package
     (name "python-distutils-extra")