summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-10-20 23:45:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-23 19:31:39 +0200
commit999d964d64a57eed7ce5790f1194118bdac5aae4 (patch)
tree011f120054818ea1e3760c40eacf18b2c704bed4 /gnu/packages
parent0990edfecb5311f96c2200372710b9e4a70d2c5e (diff)
downloadguix-999d964d64a57eed7ce5790f1194118bdac5aae4.tar.gz
gnu: Add python-flask-restful.
* gnu/packages/python.scm (python-flask-restful): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b3002235ca..80335c46b6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11254,3 +11254,34 @@ useful as a validator for JSON data.")
     (description
       "This package contains a library for parsing ISO 8601 datetime strings.")
     (license license:bsd-3)))
+
+(define-public python-flask-restful
+  (package
+    (name "python-flask-restful")
+    (version "0.3.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Flask-RESTful" version))
+        (sha256
+          (base32
+            "0hjcmdb56b7z4bkw848lxfkyrpnkwzmqn2dgnlv12mwvjpzsxr6c"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-aniso8601" ,python-aniso8601)
+        ("python-flask" ,python-flask)
+        ("python-pycrypto" ,python-pycrypto)
+        ("python-pytz" ,python-pytz)))
+    (native-inputs
+      `(;; Optional dependency of Flask. Tests need it.
+        ("python-blinker" ,python-blinker)
+        ("python-mock" ,python-mock) ; For tests
+        ("python-nose" ,python-nose) ; For tests
+        ("python-sphinx" ,python-sphinx)))
+    (home-page
+      "https://www.github.com/flask-restful/flask-restful/")
+    (synopsis
+      "Flask module for creating REST APIs")
+    (description
+      "This package contains a Flask module for creating REST APIs.")
+    (license license:bsd-3)))