summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-02 13:25:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-03 17:58:55 +0200
commitfab43c6b84635200070c708d4220132be18dd239 (patch)
tree7ee7b3fb17904f684c19da7f8f6853845c16c8a3 /gnu/packages
parent3568b8234a64b0c34c9166ae2fddb6592b78002a (diff)
downloadguix-fab43c6b84635200070c708d4220132be18dd239.tar.gz
gnu: Add r-loomr.
* gnu/packages/bioinformatics.scm (r-loomr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0619ea66b0..f2c460883e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13280,3 +13280,32 @@ cases include:
   divergence below ~15%.
 @end enumerate\n")
     (license license:expat)))
+
+(define-public r-loomr
+  (let ((commit "df0144bd2bbceca6fadef9edc1bbc5ca672d4739")
+        (revision "1"))
+    (package
+      (name "r-loomr")
+      (version (git-version "0.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mojaveazure/loomR.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1b1g4dlmfdyhn56bz1mkh9ymirri43wiz7rjhs7py3y7bdw1s3yr"))))
+      (build-system r-build-system)
+      (propagated-inputs
+       `(("r-r6" ,r-r6)
+         ("r-hdf5r" ,r-hdf5r)
+         ("r-iterators" ,r-iterators)
+         ("r-itertools" ,r-itertools)
+         ("r-matrix" ,r-matrix)))
+      (home-page "https://github.com/mojaveazure/loomR")
+      (synopsis "R interface for loom files")
+      (description "This package provides an R interface to access, create,
+and modify loom files.  loomR aims to be completely compatible with loompy.")
+      (license license:gpl3))))