summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-05 19:30:24 +0200
committerDavid Craven <david@craven.ch>2016-08-28 14:04:53 +0200
commit05b59190df900913bfe5f141cc7ff1252219bfeb (patch)
treee25c00a0b89bb255def4393b264aba774733110b /gnu/packages
parent6a6c9d433263fe353632e43961b709084ab1852f (diff)
downloadguix-05b59190df900913bfe5f141cc7ff1252219bfeb.tar.gz
gnu: Add python-schematics.
* gnu/packages/python.scm (python-schematics): New variable.
(python2-schematics): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e024e7431..bab19b338e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10103,3 +10103,35 @@ interface for programs.")
       (native-inputs
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))
+
+(define-public python-schematics
+  (package
+    (name "python-schematics")
+    (version "1.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://github.com/schematics/schematics/archive/v" version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "19v1i69bf3bzarfxmbv0v6ivpcn758x3shvbiy9l2hy0lvqwnp6l"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-six" ,python-six)))
+    (arguments
+     `(#:tests? #f)) ; requires a bunch of not very nice packages with fixed
+                     ; version requirements (eg python-coveralls)
+    (home-page "https://github.com/schematics/schematics")
+    (synopsis "Python Data Structures for Humans")
+    (description "Python Data Structures for Humans.")
+    (license license:bsd-3)
+    (properties `((python2-variant . ,(delay python2-schematics))))))
+
+(define-public python2-schematics
+  (let ((base (package-with-python2 (strip-python2-variant python-schematics))))
+    (package (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))