summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2017-06-29 14:46:07 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-29 15:21:17 +0200
commit3ab869b63fc43c8d13864d711c2dc55fb3691456 (patch)
tree2a690f74dc5dca38438b25dde5c6bb96dfaebb33 /gnu/packages
parent2eb95ade8f08bfd418b1470f1093c5b4bf2332ee (diff)
downloadguix-3ab869b63fc43c8d13864d711c2dc55fb3691456.tar.gz
gnu: lapack: Install libraries to PREFIX/lib, not PREFIX/lib64.
This fixes a regression introduced in
ef39a17717a10a7f406730258acfdb07934c7255, which would break
python-scipy ("undefined reference to `zungqr_'").

* gnu/packages/maths.scm (lapack)[arguments]: Add
"-DCMAKE_INSTALL_LIBDIR" to #:configure-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 851694bd4d..5e4cd85860 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -442,11 +442,18 @@ large scale eigenvalue problems.")
     (inputs `(("fortran" ,gfortran)
               ("python" ,python-2)))
     (arguments
-     `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"
-                           "-DLAPACKE=ON"
-
-                           ;; Build the 'LAPACKE_clatms' functions.
-                           "-DLAPACKE_WITH_TMG=ON")
+     `(#:configure-flags (list
+                          ;; Install to PREFIX/lib (the default is
+                          ;; PREFIX/lib64).
+                          (string-append "-DCMAKE_INSTALL_LIBDIR="
+                                         (assoc-ref %outputs "out")
+                                         "/lib")
+
+                          "-DBUILD_SHARED_LIBS:BOOL=YES"
+                          "-DLAPACKE=ON"
+
+                          ;; Build the 'LAPACKE_clatms' functions.
+                          "-DLAPACKE_WITH_TMG=ON")
        #:phases (alist-cons-before
                  'check 'patch-python
                  (lambda* (#:key inputs #:allow-other-keys)