summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-20 19:06:48 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-04-16 17:02:33 +0300
commit5b6d67476056fdadfad2de21b5fc4ff14999c047 (patch)
treec0a5703c0ff5dcf7f9bc7d93d86f56a155e5d8a6 /gnu/packages
parent086bfb37af3db6833992bfb0321713c74690d994 (diff)
downloadguix-5b6d67476056fdadfad2de21b5fc4ff14999c047.tar.gz
gnu: Add emacs-cl-generic.
* gnu/packages/emacs.scm (emacs-cl-generic): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c455a142d6..9d212eee37 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7665,3 +7665,24 @@ match and total match information in the mode-line in various search modes.")
       (description
        "This package provides an Emacs Lisp interface for PostgreSQL.")
       (license license:gpl3+))))
+
+(define-public emacs-cl-generic
+  (package
+    (name "emacs-cl-generic")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/cl-generic-"
+                           version ".el"))
+       (sha256
+        (base32
+         "0vb338bhjpsnrf60qgxny4z5rjrnifahnrv9axd4shay89d894zq"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/seq.html")
+    (synopsis
+     "Forward @code{cl-generic} compatibility for Emacs before version 25")
+    (description "This package provides a subset of the features of the
+@code{cl-generic} package introduced in Emacs-25, for use on previous
+@code{emacsen}.")
+    (license license:gpl3+)))