summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKyle Andrews <kyle@posteo.net>2022-05-12 02:10:25 +0000
committerRicardo Wurmus <rekado@elephly.net>2022-12-29 20:56:15 +0100
commit03544dd8e8a1a94e88e097e7442b469f3a999232 (patch)
treeffab0c2811a6f387200d4655e256afc1ea6f9428 /gnu/packages
parent15d9578e1d73a67d344709cc9a7ea85efac42e7b (diff)
downloadguix-03544dd8e8a1a94e88e097e7442b469f3a999232.tar.gz
gnu: Add r-unglue.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c54329614c..cf0d801073 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18983,6 +18983,26 @@ methods.")
     ;; Any version of the GPL
     (license license:gpl2+)))
 
+(define-public r-unglue
+  (package
+    (name "r-unglue")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "unglue" version))
+       (sha256
+        (base32 "0w8ld4xllx0lj1jz8i2sj92f8136hlwri1d8ldpg1ymxj7aw93vg"))))
+    (properties `((upstream-name . "unglue")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=unglue")
+    (synopsis "Extract matched substrings using a pattern")
+    (description
+     "This package lets you use syntax inspired by the package @code{glue} to
+extract matched substrings in a more intuitive and compact way than by using
+standard regular expressions.")
+    (license license:gpl3)))
+
 (define-public r-untb
   (package
     (name "r-untb")