summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-22 22:25:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-23 07:47:03 +0300
commit7ca6830482d799677030c2e1631c54754f143808 (patch)
tree3bebb23efe2960773ed3168a748e142f3c33b9c2 /gnu/packages
parentff1e2b59bf625a5e07a70b1863c13ffe3429c6a3 (diff)
downloadguix-7ca6830482d799677030c2e1631c54754f143808.tar.gz
gnu: python2-validictory: Add missing input.
* gnu/packages/python.scm (python2-validictory)[native-inputs]: Add
python2-setuptools.
(python-validictory)[properties]: New field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9019fc3b35..c3bb28af56 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11222,7 +11222,13 @@ is used by PostgreSQL and the OpenSSH Server for example.")
 The schema format is based on the JSON Schema
 proposal (http://json-schema.org), so combined with json the library is also
 useful as a validator for JSON data.")
-  (license license:expat)))
+  (license license:expat)
+  (properties `((python2-variant . ,(delay python2-validictory))))))
 
 (define-public python2-validictory
-    (package-with-python2 python-validictory))
+  (let ((base (package-with-python2
+               (strip-python2-variant python-validictory))))
+    (package
+      (inherit base)
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-native-inputs base))))))