summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-11-09 16:46:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 18:04:36 +0100
commit213e72a18dc20ba4ae1275e1f48104737c2a7526 (patch)
tree08ff234e29c86ceb006cdf3460b66e1c25fcbecc /gnu/packages
parentf338e4807f71503071da1af54b887e7f08a078da (diff)
downloadguix-213e72a18dc20ba4ae1275e1f48104737c2a7526.tar.gz
gnu: Add r-multicool.
* gnu/packages/cran.scm (r-multicool): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6840a2fc66..06bdaa8d61 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7422,3 +7422,24 @@ various standard 3D file formats including WebGL, PLY, OBJ, STL as well as 2D
 image formats, including PNG, Postscript, SVG, PGF.")
     ;; Any version of the GPL.
     (license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-multicool
+  (package
+    (name "r-multicool")
+    (version "0.1-10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "multicool" version))
+       (sha256
+        (base32
+         "1ybg9piya9psqg42w9i3zsnavbxhkfklfwl7cb420i5nkq6wpc2v"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/multicool/")
+    (synopsis "Permutations of multisets in cool-lex order")
+    (description
+     "This package provides a set of tools to permute multisets without loops
+or hash tables and to generate integer partitions.  Cool-lex order is similar
+to colexicographical order.")
+    (license license:gpl2)))