summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:11:11 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:44 -0500
commitb37d0c825fa33a25cbd619402e9a31991f31ec50 (patch)
treeb119b5a6d12db0b1c09baaddd34327273ac93891 /gnu/packages
parent10707d572034e7389211cbe3df30dd92f93124f7 (diff)
downloadguix-b37d0c825fa33a25cbd619402e9a31991f31ec50.tar.gz
gnu: Add ghc-tasty-lua.
* gnu/packages/haskell-check.scm (ghc-tasty-lua): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 8fac25a6d0..456ef3089e 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -261,6 +261,31 @@ test framework.")
 tasty.")
     (license license:expat)))
 
+(define-public ghc-tasty-lua
+  (package
+    (name "ghc-tasty-lua")
+    (version "0.2.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "tasty-lua/tasty-lua-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0xlj36rrhkx312h7smx6ay20rhlhxvw2ma2ckdnzv1pvmdn6p5qx"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-file-embed" ,ghc-file-embed)
+       ("ghc-hslua" ,ghc-hslua)
+       ("ghc-tasty" ,ghc-tasty)))
+    (native-inputs
+     `(("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+    (home-page "https://github.com/hslua/tasty-lua")
+    (synopsis "Write tests in Lua, integrate into tasty")
+    (description "This package gives users the ability to define tasty tests
+from Lua.")
+    (license license:expat)))
+
 (define-public ghc-tasty-th
   (package
     (name "ghc-tasty-th")