summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 14:01:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 14:07:39 +0200
commitb55e64d49ffe1319564460eb21f89a0831b95833 (patch)
tree6923434b5ad4a745ae9d59bd6e53a00b0f56e5a4 /gnu/packages
parent822fcaf8d83c2fbbaff53f8a0306725ebec6c90b (diff)
downloadguix-b55e64d49ffe1319564460eb21f89a0831b95833.tar.gz
gnu: Add r-ps.
* gnu/packages/cran.scm (r-ps): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 24c540de56..59c74c29f5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -461,6 +461,24 @@ print, summary, plot, update, etc.
 @end itemize\n")
     (license license:gpl2)))
 
+(define-public r-ps
+  (package
+    (name "r-ps")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ps" version))
+       (sha256
+        (base32 "1zm9qkyvy1fvcjvmgw51iqw8x1xzkpy7rx7xnchwfj0xpzal0ljx"))))
+    (build-system r-build-system)
+    (home-page "http://ps.r-lib.org")
+    (synopsis "List, query, and manipulate system processes")
+    (description
+     "The ps package implements an API to list, query, and manipulate system
+processes.  Most of its code is based on the @code{psutil} Python package.")
+    (license license:bsd-3)))
+
 (define-public r-rcpp
   (package
     (name "r-rcpp")