summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-11 17:42:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-14 00:05:12 +0200
commitb97b8b44ca34d2a6282dd90ab96957d650840dc5 (patch)
treefaf35b6c1656630b3c546a69f33eac8ac7a54c24 /gnu/packages
parent4187e5401fa6074a554cbd24a7092ee8df1829ab (diff)
downloadguix-b97b8b44ca34d2a6282dd90ab96957d650840dc5.tar.gz
gnu: progress: Fix cross-compilation.
* gnu/packages/admin.scm (progress)[arguments]: Use CC-FOR-TARGET and a
target-specific pkg-config when cross-compiling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9c5ab3be13..d34864505a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -231,8 +231,14 @@ usual file attributes can be checked for inconsistencies.")
      `(("ncurses" ,ncurses)))
     (arguments
      `(#:tests? #f                      ; no test suite
-       #:make-flags (list "CC=gcc"
-                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:make-flags
+       (let ((target ,(%current-target-system)))
+         (list ,(string-append "CC=" (cc-for-target))
+               (string-append "PKG_CONFIG="
+                              (if target
+                                  (string-append target "-pkg-config")
+                                  "pkg-config"))
+               (string-append "PREFIX=" (assoc-ref %outputs "out"))))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))         ; no configure script