summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-08-27 16:41:15 +0200
committerLeo Famulari <leo@famulari.name>2020-08-27 12:26:25 -0400
commitc849446b82c1c091bd521d8111349867bc45e622 (patch)
treeb2ba0a936a05fe63b8dcfb35c739f4f45c6589b4 /gnu/packages
parentf2d70885c3e8b856d91b33801ba701a0038a0814 (diff)
downloadguix-c849446b82c1c091bd521d8111349867bc45e622.tar.gz
gnu: Add python-safety.
* gnu/packages/python-xyz.scm (python-safety): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 26ee801419..cd3b35832f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21773,3 +21773,35 @@ dates in almost any string formats commonly found on web pages.")
     (synopsis "Parser for Python dependency files")
     (description "This package provides a parser for Python dependency files.")
     (license license:expat)))
+
+(define-public python-safety
+  (package
+    (name "python-safety")
+    (version "1.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "safety" version))
+        (sha256
+          (base32
+            "1j801xsxfzavjbzhhc934awvnk1b7jc0qsw3jp3ys0241mlj1gr3"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-tests
+           (lambda _
+             (substitute* "tests/test_safety.py"
+               ;; requires network
+               (("def test_check_live") "def _test_check_live"))
+             #t)))))
+    (propagated-inputs
+      `(("python-click" ,python-click)
+        ("python-dparse" ,python-dparse)
+        ("python-packaging" ,python-packaging)
+        ("python-requests" ,python-requests)))
+    (home-page "https://github.com/pyupio/safety")
+    (synopsis "Check installed dependencies for known vulnerabilities")
+    (description "Safety checks installed dependencies for known vulnerabilities.
+By default it uses the open Python vulnerability database Safety DB.")
+  (license license:expat)))