summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-15 12:31:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-15 22:09:06 +0200
commiteefa30c1c6db0772fc1af16de57e71b607903b56 (patch)
tree7bcbcddb82ef8894fdccd2f3f576c76b2ce2bcf3 /gnu/packages
parent95b90decd3303d691b5c3d305f7cef0c7e60182d (diff)
downloadguix-eefa30c1c6db0772fc1af16de57e71b607903b56.tar.gz
gnu: flint: Update to 2.6.3.
* gnu/packages/algebra.scm (flint): Update to 2.6.3.
[license]: Update to LGPL 2.1+.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2fca9ec86c..6d1a93039d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -440,15 +440,13 @@ or text interfaces) or as a C++ library.")
 (define-public flint
   (package
    (name "flint")
-   ;; When updating this package, change its licence to lgpl2.1+.
-   ;; https://github.com/wbhart/flint2/issues/812
-   (version "2.6.2")
+   (version "2.6.3")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://flintlib.org/flint-" version ".tar.gz"))
       (sha256
-       (base32 "1np1p8dx4g3jnlfr1sxmi1jdk2pb57crskm0ch2w2l1v7h8lb6sz"))))
+       (base32 "1qrf6hzbbmg7mhkhbb0bab8z2xpdnba5cj4kmmf72lzs0457a6nf"))))
    (build-system gnu-build-system)
    (inputs
     `(("ntl" ,ntl)))
@@ -490,7 +488,7 @@ Operations that can be performed include conversions, arithmetic,
 GCDs, factoring, solving linear systems, and evaluating special
 functions.  In addition, FLINT provides various low-level routines for
 fast arithmetic.")
-   (license license:gpl2+)
+   (license license:lgpl2.1+)
    (home-page "http://flintlib.org/")))
 
 (define-public arb