summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2019-02-25 18:42:55 +0100
committerClément Lassieur <clement@lassieur.org>2019-02-25 18:44:52 +0100
commit089a2c51ff4d4d8ddd180001b25535019c0d35c0 (patch)
treec09eadd4484d406f2ae9e64b31004fbc88703edb /gnu/packages
parente8ffa38289758e11412e83dad115a686965db78d (diff)
downloadguix-089a2c51ff4d4d8ddd180001b25535019c0d35c0.tar.gz
gnu: Add emacs-amx.
* gnu/packages/emacs-xyz.scm (emacs-amx): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 871721af3a..1a8ca3bf9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13183,3 +13183,27 @@ used to link to certain Magit buffers.  Use the command
 Later you can insert it into an Org buffer using the command
 @code{org-insert-link}.")
       (license license:gpl3+))))
+
+(define-public emacs-amx
+  (package
+    (name "emacs-amx")
+    (version "3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/DarwinAwardWinner/amx")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0bb8y1dmzyqkrb4mg6zndcsxppby3glridv2aap2pv05gv8kx7mj"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-s" ,emacs-s)))
+    (home-page "https://github.com/DarwinAwardWinner/amx")
+    (synopsis "Alternative interface for M-x")
+    (description "Amx is an alternative interface for M-x in Emacs.  It
+provides several enhancements over the ordinary
+@code{execute-extended-command}, such as prioritizing your most-used commands
+in the completion list and showing keyboard shortcuts, and it supports several
+completion systems for selecting commands, such as ido and ivy.")
+    (license license:gpl3+)))