summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-21 21:38:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:38:39 +0200
commitb78891b0120c2e6f7752912d43bc59e18ed9c465 (patch)
tree33d045136a302e77b80b5cfc4a8b4608ec0eb293 /gnu/packages
parent3f1c722ec74dcf81833ffc7b2d4151241b31540e (diff)
downloadguix-b78891b0120c2e6f7752912d43bc59e18ed9c465.tar.gz
gnu: r-rmarkdown: Ensure temporary files can be deleted.
* gnu/packages/statistics.scm (r-rmarkdown)[arguments]: Add phase
"copy-files-without-mode".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 853a259c85..2a9a31e3e2 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1953,6 +1953,20 @@ encoder/decoder, round-off-error-free sum and cumsum, etc.")
             "0c7gs9c8xdjfxviw0syh13pf3vys2b2ssixmnyqbji64xdscn7pz"))))
     (properties `((upstream-name . "rmarkdown")))
     (build-system r-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; See https://github.com/rstudio/rmarkdown/pull/800
+         ;; The resource files are in the store and have mode 444.  After
+         ;; copying the files R fails to remove them again because it doesn't
+         ;; have write access to them.
+         (add-after 'unpack 'copy-files-without-mode
+           (lambda _
+             (substitute* "R/render.R"
+               (("file.copy\\(from = from," prefix)
+                (string-append prefix
+                               " copy.mode = FALSE, ")))
+             #t)))))
     (propagated-inputs
      `(("r-catools" ,r-catools)
        ("r-htmltools" ,r-htmltools)