summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:14 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:08:50 +0100
commit048217e73c9ed6459ec8252163335c2982deefc6 (patch)
tree4cece1e0b8ceb1915a369a07d8ea7c629d7b99cd /gnu/packages
parent7a19cb115f0cc91b8542f86c398384b6bb594003 (diff)
downloadguix-048217e73c9ed6459ec8252163335c2982deefc6.tar.gz
gnu: Add ocaml5.0-crowbar.
* gnu/packages/ocaml.scm (ocaml5.0-crowbar): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4095c9231c..1ca3c19842 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8839,12 +8839,21 @@ document and by the text width.")
            ocaml-uunf
            ocaml-uutf
            ocaml-pprint))
+    (properties `((ocaml5.0-variant . ,(delay ocaml5.0-crowbar))))
     (synopsis "Ocaml library for tests, let a fuzzer find failing cases")
     (description "Crowbar is a library for testing code, combining
 QuickCheck-style property-based testing and the magical bug-finding powers of
 @uref{http://lcamtuf.coredump.cx/afl/, afl-fuzz}.")
     (license license:expat)))
 
+(define-public ocaml5.0-crowbar
+  (package-with-ocaml5.0
+   (package
+     (inherit ocaml-crowbar)
+     ;; Tests require ocaml-calendar which does not work with OCaml 5.0
+     (arguments `(#:tests? #f))
+     (properties '()))))
+
 (define-public ocaml-eqaf
   (package
     (name "ocaml-eqaf")