summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-22 18:40:25 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 18:58:09 +0200
commit103f488ecb1ebe733cafd1a6b3ceab20217d627b (patch)
tree31a5f006b3964daace2867eba0dbb59d891e371d /gnu/packages
parent456eeaea8edf00c10a752883e4e1d4c261e7ca80 (diff)
downloadguix-103f488ecb1ebe733cafd1a6b3ceab20217d627b.tar.gz
gnu: texlive-tools: Remove redundant definition.
* gnu/packages/tex.scm (texlive-tools): Remove second definition.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 314a67ae74..7fea6d3e53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10016,37 +10016,6 @@ used in place of @code{tabular}, @code{tabular*} and @code{tabularx}
 environments, as well as the @code{array} environment in maths mode.")
       (license license:lppl1.3+))))
 
-(define-public texlive-tools
-  (let ((template (simple-texlive-package
-                   "texlive-tools"
-                   (list "/doc/latex/tools/"
-                         "/source/latex/tools/")
-                   (base32
-                    "1xas0b69r3d5x4zhcqysgybyqaikd9avv6r1bdckb947id3iaz58"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/tools")
-         ((#:build-targets _ '())
-          ''("tools.ins"))
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'chdir
-               (lambda _ (chdir "source/latex/tools") #t))))))
-      (home-page "https://www.ctan.org/tex-archive/macros/latex/required/tools/")
-      (synopsis "LaTeX standard tools bundle")
-      (description "This package provides a collection of simple tools that
-are part of the LaTeX required tools distribution, comprising the packages:
-@code{afterpage}, @code{array}, @code{bm}, @code{calc}, @code{dcolumn},
-@code{delarray}, @code{enumerate}, @code{fileerr}, @code{fontsmpl},
-@code{ftnright}, @code{hhline}, @code{indentfirst}, @code{layout},
-@code{longtable}, @code{multicol}, @code{rawfonts}, @code{showkeys},
-@code{somedefs}, @code{tabularx}, @code{theorem}, @code{trace},
-@code{varioref}, @code{verbatim}, @code{xr}, and @code{xspace}.")
-      (license license:lppl1.3+))))
-
 (define-public texlive-latex-xkeyval
   (package
     (name "texlive-latex-xkeyval")