summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2021-12-14 20:17:13 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-01-16 11:36:10 +0100
commit1471219a8aabd2d8ad1f6bf1216c734ce73ae175 (patch)
treeca16311e8b8c5fc826ca7d4e4edec8c9c3b4193f /gnu/packages
parent711f0e683c59fc082d6ed3d9d024a9452d0a95c6 (diff)
downloadguix-1471219a8aabd2d8ad1f6bf1216c734ce73ae175.tar.gz
gnu: deluge: Remove reference of build-time librsvg
* gnu/packages/bittorrent.scm (deluge): Do it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bittorrent.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index d23e93be34..eac66713ea 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -570,9 +570,19 @@ features.")
                (("names='ngettext'") "names=['ngettext']"))
              #t))
          (add-after 'install 'wrap
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
              (let ((out               (assoc-ref outputs "out"))
-                   (gi-typelib-path   (getenv "GI_TYPELIB_PATH")))
+                   (gi-typelib-path
+                    (string-join (filter
+                                  (lambda (x) (not (string-prefix?
+                                                    (assoc-ref
+                                                     (or native-inputs inputs)
+                                                     "librsvg")
+                                                    x)))
+                                  (string-split
+                                   (getenv "GI_TYPELIB_PATH")
+                                   #\:))
+                                 ":")))
                (for-each
                 (lambda (program)
                   (wrap-program program