summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-14 20:09:24 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 21:30:00 +0100
commit169b306e48eaa9af13e9c95862aac066f1128ab8 (patch)
tree7cc33dae72e281170432b987e49ed6dd88efa001 /gnu/packages
parentea5b61dbf4c313b92fd6319e7290386b0e83e3df (diff)
downloadguix-169b306e48eaa9af13e9c95862aac066f1128ab8.tar.gz
gnu: python-qtconsole: Enable tests.
* gnu/packages/python-xyz.scm (python-qtconsole)[arguments]: Remove #:tests?.
<#:phases>: Set HOME and skip a failing test in the 'pre-check phase.
[native-inputs]: Add python-flaky.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12fcb8e83e..eb2e54da35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12666,23 +12666,21 @@ Jupyter kernels such as IJulia and IRKernel.")
         (base32 "013qgpsm8jzcz3prhq7sxs36l8f7fgagmn3xa010gfhxf7cfldpj"))))
     (build-system python-build-system)
     (arguments
-     ;; XXX: Tests are disabled, because this package needs python-ipython 7,
-     ;; but we only have the LTS version 5.x.  This means that there might be
-     ;; runtime errors, but since this is a dependency of the Jupyter package,
-     ;; and Jupyter can be used without the qtconsole we can overlook this for
-     ;; now.
-     `(#:tests? #f
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda _
-             (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             (setenv "HOME" "/tmp")
+             ;; FIXME: skip a failing test.
+             (substitute* "qtconsole/tests/test_jupyter_widget.py"
+               (("def test_other_output") "def _test_other_output")))))))
     (propagated-inputs
      (list python-ipykernel python-ipython-genutils python-jupyter-client
            python-jupyter-core python-pygments python-pyqt python-pyzmq
            python-qtpy python-traitlets))
     (native-inputs
-     (list python-pytest))
+     (list python-flaky python-pytest))
     (home-page "https://jupyter.org")
     (synopsis "Jupyter Qt console")
     (description "This package provides a Qt-based console for Jupyter with