summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:12:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commitcf4a0c1f67003146057597363f06bb0056687e0f (patch)
tree26d5b99f480407a20c61b3e6f3a323766ab66c48 /gnu/packages
parent71b0d280f7c1dcd6afa735314c970f44b465f6a4 (diff)
downloadguix-cf4a0c1f67003146057597363f06bb0056687e0f.tar.gz
gnu: Add julia-libgpg-error-jll.
* gnu/packages/julia-jll.scm (julia-libgpg-error-jll): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 6d8230b85b..87cd840b9e 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -33,6 +33,7 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages julia)
@@ -695,6 +696,44 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This package provides a wrapper for the libffi library.")
     (license license:expat)))
 
+(define-public julia-libgpg-error-jll
+  (package
+    (name "julia-libgpg-error-jll")
+    (version "1.42.0+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Libgpg_error_jll.jl")
+               (commit (string-append "Libgpg_error-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0jmsn0mhn6b35b5awbrlpjjszknsplr62li574fkgwfxlfixb8iy"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                  (("generate_wrapper_header.*")
+                   (string-append
+                     "generate_wrapper_header(\"Libgpg_error\", \""
+                     (assoc-ref inputs "libgpg-error") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libgpg-error" ,libgpg-error)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Libgpg_error_jll.jl")
+    (synopsis "libgpg-error library wrappers")
+    (description "This package provides a wrapper for the libgpg-error library.")
+    (license license:expat)))
+
 (define-public julia-libiconv-jll
   (package
     (name "julia-libiconv-jll")