summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-10 23:51:27 +0100
committerVinicius Monego <monego@posteo.net>2023-05-14 16:34:22 -0300
commitda6e6d38f35d6c2bf36ecb194e8f704d5e57af06 (patch)
tree801f849d16dad23396d022f49698c990f1eb8f4d /gnu/packages
parentede269edd05f9819d2b62d30a493099e1f754615 (diff)
downloadguix-da6e6d38f35d6c2bf36ecb194e8f704d5e57af06.tar.gz
gnu: python-pytest-httpx: Update to 0.22.0, fix build.
* gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.22.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Do not override the 'check phase.

Signed-off-by: Vinicius Monego <monego@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f272a252fc..6c5f45d4b5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2530,7 +2530,7 @@ parametrize.  This plugin allows you to use all four.")
 (define-public python-pytest-httpx
   (package
     (name "python-pytest-httpx")
-    (version "0.21.0")
+    (version "0.22.0")
     (source
      (origin
        ;; pypi package doesn't include the tests
@@ -2540,16 +2540,8 @@ parametrize.  This plugin allows you to use all four.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "12mcy1f5d5cq3rqrqgi2ar0qvzw62ibys17hw6dsdfd0j2syck4r"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (setenv "PYTHONPATH" (getcwd))
-               (invoke "pytest" "-vv")))))))
+        (base32 "1ncpd74hmsz4sadvjg99fnfscxpgh3mc2siini0dhxzwgwdkk5i7"))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-httpx))
     (native-inputs (list python-pytest python-pytest-asyncio))
     (home-page "https://colin-b.github.io/pytest_httpx/")