summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 21:43:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:55 -0400
commite3d2650726e0345b52649558d9319da3e6a8898a (patch)
tree16967f143aeb51a5111384dacc426fbf969d0216 /gnu/packages
parent5125d005eddc5e6597563a1cebb036075f775021 (diff)
downloadguix-e3d2650726e0345b52649558d9319da3e6a8898a.tar.gz
gnu: python-pygit2: Update to 1.9.2 and enable tests.
* gnu/packages/python-xyz.scm (python-pygit2): Update to 1.9.2.
[tests?]: Delete argument.
[phases]{check}: New phase override.
[description]: Fix sentence.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 508753fd50..f58510ae8c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5662,24 +5662,27 @@ readable format.")
 (define-public python-pygit2
   (package
     (name "python-pygit2")
-    (version "1.9.1")
+    (version "1.9.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pygit2" version))
        (sha256
-        (base32 "1jdr6z1il03nifwgpcdf95w6xzzbfzdkcqq5dcqjaa0rnv1pjr7g"))))
+        (base32 "068bwhirigbh2435abyv4shdxgxvyfqf4dxfmhd4hihivwrl9290"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f))            ; tests don't run correctly in our environment
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-v")))))))
     (propagated-inputs
      (list python-cached-property python-cffi libgit2))
     (native-inputs
      (list python-pytest))
     (home-page "https://github.com/libgit2/pygit2")
     (synopsis "Python bindings for libgit2")
-    (description "Pygit2 is a set of Python bindings to the libgit2 shared
-library, libgit2 implements Git plumbing.")
+    (description "Pygit2 is a set of Python bindings to the libgit2 shared library.")
     ;; GPL2.0 only, with linking exception.
     (license license:gpl2)))