summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-12-17 07:41:23 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2018-12-20 12:04:04 +0100
commit03a45a40227d97ccafeb49c4eb0fc7539f4d2127 (patch)
tree87bad9772200929492da2f86eeb3e38f94183b00 /gnu/packages
parentb02dc758a5316a8ba164d65f3d0c19fc2e21b408 (diff)
downloadguix-03a45a40227d97ccafeb49c4eb0fc7539f4d2127.tar.gz
bootstrap: srfi-43: Remove.
* gnu/packages/bootstrap.scm (%bootstrap-inputs): Remove srfi-43.
(srfi-43): Remove.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bootstrap.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 760344ba5a..72e3d0847f 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -50,8 +50,7 @@
             %bootstrap-glibc
             %bootstrap-inputs
             %bootstrap-mescc-tools
-            %bootstrap-mes
-            %srfi-43))
+            %bootstrap-mes))
 
 ;;; Commentary:
 ;;;
@@ -712,15 +711,6 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
     (home-page #f)
     (license gpl3+)))
 
-(define %srfi-43
-  (origin
-    (method url-fetch)
-    (uri "http://git.savannah.gnu.org/cgit/guile.git/plain/module/srfi/srfi-43.scm?h=stable-2.0")
-    (file-name "srfi-43.scm")
-    (sha256
-     (base32
-      "0rnkppwdkxbzkgp9s9ccmby9f7p3ijxjlmvj0pzqxwmrmpy7jwmb"))))
-
 (define (%bootstrap-inputs)
   ;; The initial, pre-built inputs.  From now on, we can start building our
   ;; own packages.
@@ -728,8 +718,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
         ((or "i686-linux" "x86_64-linux")
          `(("linux-libre-headers" ,%bootstrap-linux-libre-headers)
            ("bootstrap-mescc-tools" ,%bootstrap-mescc-tools)
-           ("mes" ,%bootstrap-mes)
-           ("srfi-43" ,%srfi-43 )))
+           ("mes" ,%bootstrap-mes)))
         (_
          `(("libc" ,%bootstrap-glibc)
            ("gcc" ,%bootstrap-gcc)