summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-21 23:21:51 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:29 -0400
commit28457ae6fe3302d426e03c9ebd4b9d187470a946 (patch)
tree9e86978ad18fbddb5acc161644feb95ea3935a32 /gnu/packages
parent76e1830c03c3d1cff64795c65aa7e660a79a909c (diff)
downloadguix-28457ae6fe3302d426e03c9ebd4b9d187470a946.tar.gz
gnu: gnome-shell: Update to 3.34.2.
* gnu/packages/gnome.scm (gnome-shell): Update to 3.34.2.
[source]: Add patch.
[native-inputs]: Add asciidoc.
[inputs]: Add gnome-autoar.
* gnu/packages/patches/gnome-shell-theme.patch: Adjust patch accordingly.
* gnu/packages/patches/gnome-shell-disable-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

(cherry picked from commit 4ac325aa9bf8dd237f5b5be7a1523d957be0067f)
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm11
-rw-r--r--gnu/packages/patches/gnome-shell-disable-test.patch25
-rw-r--r--gnu/packages/patches/gnome-shell-theme.patch30
3 files changed, 46 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f8cdf94eaa..5c8852c4ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7088,7 +7088,7 @@ properties, screen resolution, and other GNOME parameters.")
 (define-public gnome-shell
   (package
     (name "gnome-shell")
-    (version "3.32.2")
+    (version "3.34.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -7096,8 +7096,9 @@ properties, screen resolution, and other GNOME parameters.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0anlkdnqsp5fqvmg95rqjpp1ifcx5xzsvwcrdsvb1cqzbh6inmp5"))
-              (patches (search-patches "gnome-shell-theme.patch"))
+                "0k9vq2gh1nhdd6fpp7jnwx37qxaakawiqw1xnlfjvq5g5zdn8ckh"))
+              (patches (search-patches "gnome-shell-theme.patch"
+                                       "gnome-shell-disable-test.patch"))
               (modules '((guix build utils)))
               (snippet
                #~(begin
@@ -7191,7 +7192,8 @@ properties, screen resolution, and other GNOME parameters.")
                                     '("inkscape" "intltool" "glib:bin"))
                      #:outputs outputs)))))))
     (native-inputs
-     `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+     `(("asciidoc" ,asciidoc)
+       ("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
        ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
        ("gobject-introspection" ,gobject-introspection)
        ("inkscape" ,inkscape)
@@ -7212,6 +7214,7 @@ properties, screen resolution, and other GNOME parameters.")
        ("gdm" ,gdm)
        ("gdk-pixbuf" ,gdk-pixbuf+svg)
        ("gjs" ,gjs)
+       ("gnome-autoar" ,gnome-autoar)
        ("gnome-bluetooth" ,gnome-bluetooth)
        ("gnome-desktop" ,gnome-desktop)
        ("gnome-settings-daemon" ,gnome-settings-daemon)
diff --git a/gnu/packages/patches/gnome-shell-disable-test.patch b/gnu/packages/patches/gnome-shell-disable-test.patch
new file mode 100644
index 0000000000..b4c7e73cd7
--- /dev/null
+++ b/gnu/packages/patches/gnome-shell-disable-test.patch
@@ -0,0 +1,25 @@
+This test seems to require a D-Bus connection not available in the build
+environment.
+
+diff -ur /tmp/guix-build-gnome-shell-3.34.2.drv-0/gnome-shell-3.34.2/src/st/meson.build b/src/st/meson.build
+--- /tmp/guix-build-gnome-shell-3.34.2.drv-0/gnome-shell-3.34.2/src/st/meson.build	1969-12-31 19:00:00.000000000 -0500
++++ b/src/st/meson.build	2019-12-23 00:46:14.721198022 -0500
+@@ -132,18 +132,6 @@
+   sources: st_enums[1]
+ )
+ 
+-test_theme = executable('test-theme',
+-  sources: 'test-theme.c',
+-  c_args: st_cflags,
+-  dependencies: [mutter_dep, gtk_dep],
+-  build_rpath: mutter_typelibdir,
+-  link_with: libst
+-)
+-
+-test('CSS styling support', test_theme,
+-  workdir: meson.current_source_dir()
+-)
+-
+ libst_gir = gnome.generate_gir(libst,
+   sources: st_gir_sources,
+   nsversion: '1.0',
diff --git a/gnu/packages/patches/gnome-shell-theme.patch b/gnu/packages/patches/gnome-shell-theme.patch
index fc7f7caf0f..3fa0670c43 100644
--- a/gnu/packages/patches/gnome-shell-theme.patch
+++ b/gnu/packages/patches/gnome-shell-theme.patch
@@ -2,25 +2,23 @@ Adjust GNOME-Shell so that it uses a Guix theme by default.
 
 Patch by Ludovic Courtès <ludo@gnu.org>.
 
-diff --git a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
-index 76aeaa5..8eaf32e 100644
---- a/data/gnome-shell-theme.gresource.xml
-+++ b/data/gnome-shell-theme.gresource.xml
-@@ -22,6 +22,8 @@
+diff -ur a/data/gnome-shell-theme.gresource.xml b/data/gnome-shell-theme.gresource.xml
+--- a/data/gnome-shell-theme.gresource.xml	2019-12-11 15:06:31.000000000 -0500
++++ b/data/gnome-shell-theme.gresource.xml	2019-12-21 00:31:55.895866241 -0500
+@@ -19,6 +19,8 @@
      <file>no-events.svg</file>
      <file>no-notifications.svg</file>
      <file>noise-texture.png</file>
 +    <file>guix-background.png</file>
 +    <file>guix-logo.png</file>
      <file>pad-osd.css</file>
-     <file>page-indicator-active.svg</file>
-     <file>page-indicator-inactive.svg</file>
-diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
-index 54d9f39..b9badd0 100644
---- a/data/theme/gnome-shell-sass/_common.scss
-+++ b/data/theme/gnome-shell-sass/_common.scss
-@@ -1742,7 +1742,16 @@ $legacy_icon_size: 24px;
- 
+     <file alias="icons/pointer-double-click-symbolic.svg">pointer-double-click-symbolic.svg</file>
+     <file alias="icons/pointer-drag-symbolic.svg">pointer-drag-symbolic.svg</file>
+diff -ur a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
+--- a/data/theme/gnome-shell-sass/_common.scss	2019-12-11 15:06:31.000000000 -0500
++++ b/data/theme/gnome-shell-sass/_common.scss	2019-12-21 00:33:49.495832135 -0500
+@@ -1994,7 +1994,16 @@
+   }
  }
  
 -  .login-dialog-logo-bin { padding: 24px 0px; }
@@ -37,14 +35,14 @@ index 54d9f39..b9badd0 100644
    .login-dialog-banner { color: darken($osd_fg_color,10%); }
    .login-dialog-button-box { spacing: 5px; }
    .login-dialog-message-warning { color: $warning_color; }
-@@ -1889,9 +1898,10 @@ $legacy_icon_size: 24px;
+@@ -2143,9 +2152,10 @@
  }
  
  #lockDialogGroup {
--  background: #2e3436 url(resource:///org/gnome/shell/theme/noise-texture.png);
+-  background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/noise-texture.png);
 -  background-repeat: repeat;
 -}
-+  background: #2e3436 url(resource:///org/gnome/shell/theme/guix-background.png);
++  background: lighten(#2e3436, 8%) url(resource:///org/gnome/shell/theme/guix-background.png);
 +  background-repeat: no-repeat;
 +  background-size: cover;
 +  background-position: center; }