summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-28 11:37:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-28 16:05:56 +0200
commit32d5360f43908a34b3315ec7d1d558504ef5257e (patch)
treee9fa6ada0cc94bc05790cc30f1b5ad7f9be6a3b2 /gnu/packages
parentcb6f44d4e4384f481db4de8fec3f76635f32ad79 (diff)
downloadguix-32d5360f43908a34b3315ec7d1d558504ef5257e.tar.gz
gnu: z3: Unconditionally return #T from build phases.
* gnu/packages/maths.scm (z3)[arguments]: Use INVOKE in build phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6aa402b823..adc8c255ac 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3983,8 +3983,7 @@ as equations, scalars, vectors, and matrices.")
              #t))
          (add-before 'configure 'bootstrap
            (lambda _
-             (zero?
-              (system* "python" "scripts/mk_make.py"))))
+             (invoke "python" "scripts/mk_make.py")))
          ;; work around gnu-build-system's setting --enable-fast-install
          ;; (z3's `configure' is a wrapper around the above python file,
          ;; which fails when passed --enable-fast-install)
@@ -3999,12 +3998,12 @@ as equations, scalars, vectors, and matrices.")
          (add-before 'check 'make-test-z3
            (lambda _
              ;; Build the test suite executable.
-             (zero? (system* "make" "test-z3" "-j"
-                             (number->string (parallel-job-count))))))
+             (invoke "make" "test-z3" "-j"
+                     (number->string (parallel-job-count)))))
          (replace 'check
            (lambda _
              ;; Run all the tests that don't require arguments.
-             (zero? (system* "./test-z3" "/a")))))))
+             (invoke "./test-z3" "/a"))))))
     (native-inputs
      `(("which" ,which)
        ("python" ,python-wrapper)))