summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-15 10:01:42 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-15 10:01:42 +0100
commit4d0f20d91c1dd433bb383c4a0667b093b1d28c90 (patch)
tree6d0bf8f72c6d3443ef54aa1779fd89d70d11a395 /gnu/packages
parent99d5e5df2714a4ee36788b189f34e882b47b932a (diff)
downloadguix-4d0f20d91c1dd433bb383c4a0667b093b1d28c90.tar.gz
gnu: Add emacs-elmacro.
* gnu/packages/emacs-xyz.scm (emacs-elmacro): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9fdb00efb9..c917cca4d7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13532,3 +13532,28 @@ and code peeking.")
 displays as you type thanks to Helm, though @command{notmuch-search} does the
 real search.")
       (license license:gpl3+))))
+
+(define-public emacs-elmacro
+  (let ((commit "89b9b0feabafd01fee48111d67131c4c9b5fed9a"))
+    (package
+      (name "emacs-elmacro")
+      (version (git-version "1.1.0" "1" commit))
+      (home-page "https://github.com/Silex/elmacro")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "06wkzafh6vbcjf0m3sl253mgcq32p8cdv7vsfmyx51baa36938ha"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-s" ,emacs-s)
+         ("emacs-dash" ,emacs-dash)))
+      (synopsis "Convert keyboard macros to Emacs Lisp")
+      (description
+       "This package displays keyboard macros or latest interactive commands
+as Emacs Lisp.")
+      (license license:gpl3+))))