summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 16:47:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 13:22:12 +0100
commit52f622ef9fd315945f37de921c9d46997d176692 (patch)
tree8c4b33266c56d7ca9da838a7fa4211fdd5a98b43 /gnu/packages
parent58a35665d98386d98e7fbb84812d2b2282990eca (diff)
downloadguix-52f622ef9fd315945f37de921c9d46997d176692.tar.gz
gnu: python-sympy: Update to 1.0.
* gnu/packages/python.scm (python-sympy, python2-sympy): Update to 1.0.
[propagated-inputs]: Add python-mpmath.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0414e889fe..18a8b58873 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5439,7 +5439,7 @@ more advanced mathematics.")
 (define-public python-sympy
   (package
     (name "python-sympy")
-    (version "0.7.6")
+    (version "1.0")
     (source
      (origin
        (method url-fetch)
@@ -5447,8 +5447,10 @@ more advanced mathematics.")
              "https://github.com/sympy/sympy/releases/download/sympy-"
              version "/sympy-" version ".tar.gz"))
        (sha256
-        (base32 "19yp0gy4i7p4g6l3b8vaqkj9qj7yqb5kqy0qgbdagpzgkdz958yz"))))
+        (base32 "1bpzjwr9hrr7w88v4vgnj9lr6vxcldc94si13n8xpr1rv08d5b1y"))))
     (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mpmath" ,python-mpmath)))
     (home-page "http://www.sympy.org/")
     (synopsis "Python library for symbolic mathematics")
     (description