summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-11-14 15:39:56 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-11-14 15:39:56 +0100
commit5a17042e70e9ebd0d0c95b101d55ba384b05b22d (patch)
tree1400ffce96b061f2236f7ffc6dbcfcbb5384fa1e /gnu/packages
parent4dcf32b56b824efcdb181c9f4cc7ee6c8a0ba125 (diff)
downloadguix-5a17042e70e9ebd0d0c95b101d55ba384b05b22d.tar.gz
gnu: Add emacs-helm-fish-completion.
* gnu/packages/emacs-xyz.scm (emacs-helm-fish-completion): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 187b38716e..52d6e9544b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19858,3 +19858,28 @@ Flycheck plugin.  @code{cpplint} is a static code checker for C++, following
 Google guidelines.")
       (home-page "https://github.com/flycheck/flycheck-google-cpplint")
       (license license:gpl3+))))
+
+(define-public emacs-helm-fish-completion
+  (let ((commit "ef764dd123040fe67ef8b62a1c13842e940b0963")
+        (revision "1"))
+    (package
+      (name "emacs-helm-fish-completion")
+      (version (git-version "0.1" revision commit))
+      (home-page "https://github.com/emacs-helm/helm-fish-completion")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0k80kpapwfq2rv1lb0r994d0w6czl92xrmnkmrg0a05f4b3q0lb4"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("helm" ,emacs-helm)
+         ("fish-completion" ,emacs-fish-completion)))
+      (synopsis "Helm interface for Emacs fish-completion")
+      (description "Helm Fish Completion is a Helm interface for Emacs
+fish-completion.  It can be used in both Eshell and M-x shell.")
+      (license license:gpl3+))))