summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2018-08-27 18:30:01 +0300
committerAlex Kost <alezost@gmail.com>2018-08-28 12:23:52 +0300
commit8b1f8f64c80c37167cfa10aab357e0993293ac3c (patch)
tree94f2cf744a8a81101f32ad3145e91929cbd46cc5 /gnu/packages
parent3bcb305b98e02f6c9d98e7325813fc00f18f0e6c (diff)
downloadguix-8b1f8f64c80c37167cfa10aab357e0993293ac3c.tar.gz
gnu: openmw: Update to 0.44.0.
* gnu/packages/game-development.scm (openmw): Update to 0.44.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8d66317ce7..86f2877f82 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1037,23 +1037,18 @@ of use.")
     (license license:expat)))
 
 (define-public openmw
-  ;; XXX The current version does not support qt 5.11, but the upcoming
-  ;; version (0.44) will do.
-  (let ((commit "5bc073603e8c7887e015a0ef41b4cefd6e688aaf")
-        (revision "1"))
   (package
     (name "openmw")
-    (version (git-version "0.43" revision commit))
+    (version "0.44.0")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://gitlab.com/OpenMW/openmw.git")
-             (commit commit)))
-       (file-name (string-append name "-" version "-checkout"))
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/OpenMW/openmw/archive/"
+                       name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1sp4n3f1syvv0iz7n72wh226fyc0jh98cg8bvs574jvvqx6qn851"))))
+         "03fgm2f2r7y0aqlgp038pdlnllgvm3jimrp968p4nhz1sffvjzcy"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; No test target
@@ -1080,7 +1075,7 @@ the 2002 open-world RPG Morrowind.  The engine comes with its own editor,
 called OpenMW-CS which allows the user to edit or create their own original
 games.")
     (home-page "https://openmw.org")
-    (license license:gpl3))))
+    (license license:gpl3)))
 
 (define-public godot
   (package