summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:41:13 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:20 -0400
commitb0559d241b89344d7fef5313bdc1e8ca0869111b (patch)
tree7d5c3e502d76f318db1ff8dbb114b2d773fb521c /gnu/packages
parentfa76696b0084b2201e440e5f8813bdba0fdf0e08 (diff)
downloadguix-b0559d241b89344d7fef5313bdc1e8ca0869111b.tar.gz
gnu: zip: Use invoke instead of system*.
* gnu/packages/compression.scm (zip)[arguments]: Use invoke.  Remove vestigial
  '#:modules' argument.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/compression.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 766aeb44d9..ea88fb417f 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1706,14 +1706,11 @@ the actual decompression, the other input and output.")
                       (list "-f" "unix/Makefile"
                             (string-append "prefix=" out)
                             (string-append "MANDIR=" out "/share/man/man1")))
-       #:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (srfi srfi-1))
        #:phases
        (modify-phases %standard-phases
          (replace 'build
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "generic_gcc" make-flags))))
+             (apply invoke "make" "generic_gcc" make-flags)))
          (delete 'configure))))
     (home-page "http://www.info-zip.org/Zip.html")
     (synopsis "Compression and file packing utility")