summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 14:43:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:01 +0300
commitb44863d1be518ff8ef8a5ef6253a88899696bc09 (patch)
treedbbdb1b64357a9d855a6ef11351f3d9faef44bf9 /gnu/packages
parent07d7175406210434d1fb9c100dc33a7d095f1627 (diff)
downloadguix-b44863d1be518ff8ef8a5ef6253a88899696bc09.tar.gz
gnu: Add rust-antidote.
* gnu/packages/crates-io.scm (rust-antidote): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 45966389dd..d017ee6216 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28,6 +28,27 @@
 ;;; Please: Try to add new module packages in alphabetic order.
 ;;;
 
+(define-public rust-antidote
+  (package
+    (name "rust-antidote")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "antidote" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "19g2sw2qa2ibnh4x7j1snk46593jgx6y7rnvva496ynq61af5z9l"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/sfackler/rust-antidote")
+    (synopsis "Poison-free Mutex and RwLock types")
+    (description
+    "These types expose identical APIs to the standard library @code{Mutex} and
+@code{RwLock} except that they do not return @code{PoisonError}s.")
+    (license (list license:asl2.0
+                   license:expat))))
+
 (define-public rust-autocfg
   (package
     (name "rust-autocfg")