summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 14:38:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 14:39:44 +0100
commitbbf66cbf63f31aef82646ee29d643682c16f08aa (patch)
tree44ddd96ef40849d58762a4bd3cab6eaa18f75eaa /gnu/packages
parent8c3f2170c433ae01f52fd5bcaad61a729b8f9a5e (diff)
downloadguix-bbf66cbf63f31aef82646ee29d643682c16f08aa.tar.gz
gnu: arc-icon-theme: Don't use unstable tarball.
* gnu/packages/gnome.scm (arc-icon-theme)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 96a46ab964..15cd40d160 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7226,14 +7226,15 @@ simple and consistent.")
   (package
     (name "arc-icon-theme")
     (version "20161122")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/horst3180/arc-icon-theme"
-                                  "/archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1ya1cqvv8q847c0rpcg6apzky87q3h04y8jz5nmi52qk6kg8si0b"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/horst3180/arc-icon-theme.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ch3hp08qri93510hypzz6m2x4xgg2h15wvnhjwh1x1s1b7jvxjd"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases