summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-02 14:30:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-02 14:37:13 +0300
commitc4c8cfddd5ba05b30d99c4aac573634d787b7695 (patch)
treec25ada137b8f585ff540c134dcdbfe21626581b4 /gnu/packages
parentfb0b9ff1fabb3106ff72f3fe5f531b14f96bda8d (diff)
downloadguix-c4c8cfddd5ba05b30d99c4aac573634d787b7695.tar.gz
gnu: Remove ghostscript-gs definitions.
* gnu/packages/ghostscript.scm (ghostscript-wrapper, ghostscript-gs)
(ghostscript-gs/x): Remove variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ghostscript.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 714544c2e6..8f10b18074 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -204,40 +204,6 @@ output file formats and printers.")
               ("libxt" ,libxt)
               ,@(package-inputs ghostscript)))))
 
-(define (ghostscript-wrapper name ghostscript)
-  ;; Return a GHOSTSCRIPT wrapper that provides the 'gs' command.
-  ;; See <https://lists.gnu.org/archive/html/guix-devel/2016-07/msg00987.html>.
-  (package
-    (name name)
-    (version (package-version ghostscript))
-    (source #f)
-    (build-system trivial-build-system)
-    (inputs `(("ghostscript" ,ghostscript)))
-    (arguments
-     `(#:modules ((guix build utils))
-       #:builder (begin
-                   (use-modules (guix build utils))
-
-                   (let* ((out (assoc-ref %outputs "out"))
-                          (bin (string-append out "/bin"))
-                          (gs  (assoc-ref %build-inputs "ghostscript")))
-                     (mkdir-p bin)
-                     (with-directory-excursion bin
-                       (symlink (string-append gs "/bin/gsc") "gs")
-                       #t)))))
-    (synopsis "Wrapper providing Ghostscript's 'gs' command")
-    (description
-     "This package provides the @command{gs} command, which used to be
-provided by Ghostscript itself and no longer is.")
-    (license (package-license ghostscript))
-    (home-page (package-home-page ghostscript))))
-
-(define-public ghostscript-gs
-  (ghostscript-wrapper "ghostscript-gs" ghostscript))
-
-(define-public ghostscript-gs/x
-  (ghostscript-wrapper "ghostscript-gs-with-x" ghostscript/x))
-
 (define-public ijs
   (package
    (name "ijs")