summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-02-24 10:11:14 -0800
committerChris Marusich <cmmarusich@gmail.com>2021-03-10 23:02:02 -0800
commitf4cbd18d0e43d856e83b5d1a0603412d4eb8cbf1 (patch)
treea003c3494258d73adb422de3aa2e1600bbad17d1 /gnu/packages
parente5fec0cdaea952c45f94d2c2503bdc5119bdfe92 (diff)
downloadguix-f4cbd18d0e43d856e83b5d1a0603412d4eb8cbf1.tar.gz
gnu: commencement: Fix findutils-boot0 on some systems.
This fixes an issue where findutils-boot0 would fail to build ("XPASS:
test-fnmatch") on some systems, in particular powerpc64le-linux.

* gnu/packages/commencement.scm (findutils-boot0): Delete the
skip-fnmatch-test phase on any system that does not build this package using
glibc-mesboot, i.e. any system that is not x86_64-linux or i686-linux.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f6bfc27843..4de9112bc8 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2512,6 +2512,9 @@ exec " gcc "/bin/" program
               ,flags))
            ((#:phases phases '%standard-phases)
             `(modify-phases ,phases
+               ;; XXX On architectures that do not build this package using
+               ;; glibc-mesboot, this phase is not needed, so we we
+               ;; immediately delete it below.
                (add-before 'check 'skip-fnmatch-test
                  (lambda _
                    ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
@@ -2519,7 +2522,11 @@ exec " gcc "/bin/" program
                    ;; class.  Ignore it.
                    (substitute* "gnulib-tests/Makefile"
                      (("^XFAIL_TESTS =")
-                      "XFAIL_TESTS = test-fnmatch ")))))))))))
+                      "XFAIL_TESTS = test-fnmatch "))))
+               ,@(match (%current-system)
+                   ((or "x86_64-linux" "i686-linux")
+                    '())
+                   (_ '((delete 'skip-fnmatch-test)))))))))))
 
 (define file
   (package