summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-26 15:52:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-26 15:52:57 +0200
commit3d6040c13522122df496c862c0ca2ddf8b28b71c (patch)
tree1cf0199982b8aa0c2a1205c1e1ad1c9feb38e36b /gnu/packages
parentac4c0b193315d9c61b71749370ad55091154bfdb (diff)
downloadguix-3d6040c13522122df496c862c0ca2ddf8b28b71c.tar.gz
gnu: toot: Honor the #:tests? flag.
* gnu/packages/mastodon.scm (toot)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mastodon.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index f23ff062fa..4847bbeed9 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -52,9 +52,10 @@
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "py.test"))))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "py.test")))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (inputs