summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-05-02 15:43:37 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-04 18:12:40 +0100
commitc63bd847816061e76389e93dc094df98800f081b (patch)
tree8fb53d63deff6d929f113aaa76e40b1df28aa2e9 /gnu/packages
parent68c7f577d8cbb1a11a812e36c7ae1e34ccc57e62 (diff)
downloadguix-c63bd847816061e76389e93dc094df98800f081b.tar.gz
gnu: python-s3transfer: Fix build with Python 3.8.
* gnu/packages/python-web.scm (python-s3transfer)[arguments]: Add a 'patch
phase to fix a test to work under Python 3.8.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 27749246d8..56887ef9d4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2204,6 +2204,15 @@ Betamax.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             ;; There's a small issue with one test with Python 3.8, this
+             ;; change has been suggested upstream:
+             ;; https://github.com/boto/s3transfer/pull/164
+             (substitute* "tests/unit/test_s3transfer.py"
+               (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
+                "futures.Future()"))
+             #t))
          (replace 'check
            (lambda _
              ;; Some of the 'integration' tests require network access or