summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-19 19:52:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-19 19:52:11 +0300
commit02a585212f34a7c6058c40db5a7fed5a4a9b0138 (patch)
treec727d0e20142cb1dab6a0c493a226457c133afd0 /gnu/packages
parent71aa29911cf3f4e6db5f9bff9237308b5f93283d (diff)
downloadguix-02a585212f34a7c6058c40db5a7fed5a4a9b0138.tar.gz
gnu: newsboat: Fix build.
* gnu/packages/syndication.scm (newsboat)[arguments]: Move the prefix
declaration to the 'patch-source phase. Adjust other phases so they
actually build.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syndication.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index ed2fb3ba79..dc577b87f0 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -276,29 +276,21 @@ cards.")
            (lambda* (#:key vendor-dir #:allow-other-keys)
              ;; Don't keep the whole tarball in the vendor directory
              (delete-file-recursively
-               (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))
-             #t))
+               (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
          (add-after 'unpack 'patch-source
-           (lambda _
+           (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "Makefile"
-               (("Cargo.lock") ""))
-             #t))
+               (("Cargo.lock") "")
+               ;; Replace the prefix in the Makefile.
+               (("/usr/local") (assoc-ref outputs "out")))))
          (replace 'build
-           (lambda* args
-             ((assoc-ref gnu:%standard-phases 'build)
-              #:make-flags
-              (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+           (assoc-ref gnu:%standard-phases 'build))
          (replace 'check
-           (lambda* args
+           (lambda args
              ((assoc-ref gnu:%standard-phases 'check)
-              #:test-target "test"
-              #:make-flags
-              (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+              #:test-target "test")))
          (replace 'install
-           (lambda* args
-             ((assoc-ref gnu:%standard-phases 'install)
-              #:make-flags
-              (list (string-append "prefix=" (assoc-ref %outputs "out")))))))))
+           (assoc-ref gnu:%standard-phases 'install)))))
     (native-search-paths
      ;; Newsboat respects CURL_CA_BUNDLE.
      (package-native-search-paths curl))