summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 23:54:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:07 +0000
commit0bff68e44d65493bad50b6c07e7c1cfc93846986 (patch)
tree38edc6076a63c7f64f917e5083dbfaf6971ca2d6 /gnu/packages
parent527455be35c33e25cc76805a6f879d85a3624339 (diff)
downloadguix-0bff68e44d65493bad50b6c07e7c1cfc93846986.tar.gz
gnu: heimdal: Use the cross-compiled bash in "su".
* gnu/packages/kerberos.scm
  (heimdal)[arguments]<#:phases>{pre-configure}: Replace _PATH_BSHELL
  with the cross-compiled bin/sh when cross-compiling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kerberos.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 9afc6a363f..126cdf4342 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -240,9 +240,15 @@ After installation, the system administrator should generate keys using
                           '(#:key inputs #:allow-other-keys)
                           '_)
                      ,@(if (%current-target-system)
-                           '((substitute* '("appl/afsutil/pagsh.c")
+                           '((substitute* '("appl/afsutil/pagsh.c" "appl/su/su.c")
                                (("/bin/sh")
-                                (search-input-file inputs "bin/sh")))
+                                (search-input-file inputs "bin/sh"))
+                               ;; Use the cross-compiled bash instead of the
+                               ;; native bash (XXX shouldn't _PATH_BSHELL point
+                               ;; to a cross-compiled bash?).
+                               (("_PATH_BSHELL")
+                                (string-append
+                                 "\"" (search-input-file inputs "bin/sh") "\"")))
                              (substitute* '("tools/Makefile.in")
                                (("/bin/sh") (which "sh"))))
                            '((substitute* '("appl/afsutil/pagsh.c"