summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2017-06-26 16:59:11 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-26 18:16:11 +0200
commit11f0c4e871d09f3122c59f665c0ad18dcd4fc5eb (patch)
tree0f49242a255f1b041a69b1b4b34023658cf6d8d9 /gnu/packages
parentef39a17717a10a7f406730258acfdb07934c7255 (diff)
downloadguix-11f0c4e871d09f3122c59f665c0ad18dcd4fc5eb.tar.gz
gnu: lapack: Build with LAPACKE_WITH_TMG=ON.
* gnu/packages/maths.scm (lapack)[arguments]: Pass
"-DLAPACKE_WITH_TMG=ON".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b43f2d63e9..3c93e2c7ec 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -443,7 +443,10 @@ large scale eigenvalue problems.")
               ("python" ,python-2)))
     (arguments
      `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"
-                           "-DLAPACKE=ON")
+                           "-DLAPACKE=ON"
+
+                           ;; Build the 'LAPACKE_clatms' functions.
+                           "-DLAPACKE_WITH_TMG=ON")
        #:phases (alist-cons-before
                  'check 'patch-python
                  (lambda* (#:key inputs #:allow-other-keys)