summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-05 13:16:07 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-11-18 11:29:45 +0100
commit217b20e4db95db2fc86e87bd4f46ba35c4d977a1 (patch)
tree1f1f921fa06251e04379da0998a26eb719419f55 /gnu/packages
parent3ff47c666560f99e30ac7be08d934994958df031 (diff)
downloadguix-217b20e4db95db2fc86e87bd4f46ba35c4d977a1.tar.gz
gnu: Add java-jeromq.
* gnu/packages/java.scm (java-jeromq): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d2ca7f4811..432693cdd8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6960,3 +6960,38 @@ protocol-independent framework to build mail and messaging applications.")
     ;; and Distribution License("CDDL")
     (license (list license:cddl1.1
                    license:gpl2)))); with classpath exception
+
+(define-public java-jeromq
+  (package
+    (name "java-jeromq")
+    (version "0.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/zeromq/jeromq/archive/v"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "17wx8dlyqmbw77xf6d6wxnhiyky6181zpf1a48jqzz9hidz0j841"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "java-jeromq.jar"
+       #:source-dir "src/main/java"
+       #:jdk ,icedtea-8
+       #:test-exclude
+       (list
+         "**/Abstract*.java"
+         ;; Requires network
+         "**/ZBeaconTest.java"
+         ;; Failures
+         "**/CustomDecoderTest.java"
+         "**/CustomEncoderTest.java")))
+    (inputs
+     `(("java-jnacl" ,java-jnacl)))
+    (native-inputs
+     `(("java-hamcrest-core" ,java-hamcrest-core)
+       ("junit" ,java-junit)))
+    (home-page "http://zeromq.org/bindings:java")
+    (synopsis "Java binding for 0MQ")
+    (description "Jeromq provides the java bindings for 0MQ.")
+    (license license:mpl2.0)))