summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 22:47:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 23:27:11 +0200
commit22ade2684acea7c753902eeb5e94231aabbe14bf (patch)
tree6a3c6c7198f58b0c9e42c81b011cb3428ff39899 /gnu/packages
parentd8cf1b32d2c9b816807ff31ffed58a9a50d633fe (diff)
downloadguix-22ade2684acea7c753902eeb5e94231aabbe14bf.tar.gz
gnu: burp: Extend test time-outs.
* gnu/packages/backup.scm (burp)[arguments]: Add a new
‘extend-test-time-outs’ phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/backup.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 4d24dff0a3..6c1d71297f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
@@ -988,6 +988,16 @@ precious backup space.
                (base32
                 "0dm2y76z7pg17kfv6ahmh4mf2r3pg7mlwd69lvmjwssnd9vs1nn5"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'extend-test-time-outs
+           ;; The defaults are far too low for busy boxes & spinning storage.
+           (lambda _
+             (substitute* (find-files "utest" "\\.c$")
+               (("(tcase_set_timeout\\(tc_core,)[ 0-9]*(\\);.*)$" _ prefix suffix)
+                (string-append prefix " 3600" suffix "\n")))
+             #t)))))
     (inputs
      `(("librsync" ,librsync)
        ("openssl" ,openssl)